[ubuntu]解決套件更新時GPG驗證錯誤(3/27更新)

在終端機下達「sudo apt-get update」,出現以下錯誤訊息:

W: GPG error: http://ppa.launchpad.net intrepid Release: 由於沒有公鑰,下列簽名無法進行驗證: NO_PUBKEY 60D11217247D1CFF

不理這訊息也是可以繼續安裝,不過要知道,這 GPG key 是用來認證正確的軟體來源,保護你的電腦,避免受到惡意軟體的侵害。

那我們就透過 Keyserver 去找這組 GPG key 公鑰「60D11217247D1CFF」

gpg --keyserver keyserver.ubuntu.com --recv-key [KEY_ID]

在終端機輸入以下:

gpg --keyserver keyserver.ubuntu.com --recv-key 60D11217247D1CFF

會得到以下訊息,可得知這是「Launchpad PPA for OpenOffice.org Scribblers」的 GPG key。

lee@lee-laptop:~$ gpg --keyserver keyserver.ubuntu.com --recv -key 60D11217247D1CFF
gpg: 正在請求金鑰 247D1CFF 自 hkp 伺服器 keyserver.ubuntu.com
gpg: 金鑰 247D1CFF: "Launchpad PPA for OpenOffice.org Scribblers" 未改變
gpg: 處理總量: 1
gpg:              未改變的: 1

匯出存成 GPG 檔

gpg --export --armor 60D11217247D1CFF > ooo.gpg

匯入 GPG 檔

sudo apt-key add ooo.gpg

在重新執行更新套件「sudo apt-get update」就不會再出現GPG key 公鑰驗證錯誤訊息囉!

sudo apt-get update

另外也可參考這篇的討論。

快速安裝指令

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com [ID]

例如

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 60D11217247D1CFF

發表迴響